Jump to content
Sign in to follow this  
Tango

PiexGrains

Recommended Posts

I have waited a while for an opportunity to use PiexlGrains. You can do pretty cool stuff with it. My current problem is that I can't make it work with a custom shape.

The shape Is a simple .fact model built in the XZ plane with Y pointing up (as per instructions). It generates flat rectangles in the XY plane. I tried a flat extrusion instead of a 2D shape and got the same result. Am I missing something? Has anyone successfully used custom shapes with PixelGrains?

Thanks,

Christian

Share this post


Link to post
Share on other sites

Bonjour Christian

I will check it out tomorrow but is the shape linked at the plug and sitting at 0,0,0?

Have you tried increasing the Y value in the pixelgrains window?

Share this post


Link to post
Share on other sites

Allô Richard,

I would say, yes and yes. The geo is the child of PixelGrains and the shape sits at 0,0,0. It works very well with cubes. "Custom" gives me the same result as using "Plane". All I am trying to do is create the same effect using rectangles with round corners and a flat top, a straight extrusion. Unfortunately the "rounded cube" option does not generate a flat top.

Thanks,

Christian

Share this post


Link to post
Share on other sites

Christian,

I tried many custom shapes today to no avail. Possible bug. Please send me the .fact file you want to use. (send to rick@eias3d.com) I'll make a simple project for the Igors to look into.

Can you animate your camera when you use PixelGrains? I can't.

Share this post


Link to post
Share on other sites

Hi Richard,

I am animating my camera and also using a low res. video clip as source for the animation of the extrusions, it's working well. I'll send you a collected script shortly.

I am attaching a sample clip.

Christian

PixelGrains_bg.mov

Share this post


Link to post
Share on other sites

Most likely, the shape has too many vertices. I seem to remember that the plane was a fallback if something was wrong about the custom shape. try to use a simpler shape, and see if that works. I'd say fewer than 20 points..

Another thing PG isn't good at is predicting memory footprint, so there could be an issue there. and gracefully recovering from it.. A bug of course.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×