Jump to content
Sign in to follow this  

Animator cannot be opened because of a problem

Recommended Posts

Tried to open EIAS3D for the first time in a year. (I've been away from 3D illustration for awhile doing video, my other calling.)

Got dialog box saying:

'Animator cannot be opened because of a problem. Check with the developer to make sure Animator works with this version of Mac OS X. You may need to reinstall the application. Be sure to install any available updates for the application and Mac OS X. Click Report to see more detailed information and send a report to Apple.'

Replaced Animator and Camera in my EIAS 8 folder with the EIAS 8.0 Mac OSX Lion Patch from http://www.eias3d.com/downloads/ —same result. (Pondered the pre-Lion 2009 creation and modified dates on the patch. Great foresight.)

Installed the copy protection widgets to freshen my dongle.





(I appreciate the convenient, easy to find location. And only 4 installers.)

But still the same dialog box: 'Animator cannot be opened because of a problem…'

I would appreciate any thoughts on how to get EIAS3D up and running. Thank you.

Michael Morris

iMac, Lion 10.7.4

EIAS3D 8.0.0

dongle that worked on an Intel Mac a year ago

Camera opens

EIAS stuff:


Share this post

Link to post
Share on other sites

Thank for the link, Tom. It advanced me from the same issue the user above was experiencing to a new one: the system claims my hardware dongle is not plugged in. I've put in the frameworks as described by Tom after finding that the dongle installer would not function on an Intel Mac under Lion.

I know my dongle is okay, because it works on my laptop. But this brand new Mac Pro won't launch ElectricImage at all.

Are there further diagnostic steps I can take?

EIAS 8.0 (with Lion Patch)

Mac OS X 10.7.4

Mac Pro duodeca-core Intel Xeon, 32 GB RAM

Just installed Eve3 frameworks

Any insights would be appreciated!

Share this post

Link to post
Share on other sites


I was installing in a new Mac Book Pro this weekend, after manually install the frameworks, the machine didnt recognize the hardware dongle too! So, I installed the Safenet installers from the "Sphaera" post, then the dongle started to work!

Btw: amazing new machine you have! EIAS9 will love it!!



Share this post

Link to post
Share on other sites

Just installed Moutain lion and tried the Frameworks thing no luck launching EIAS 8. i get the no dongle there issue. and the links from Sphaera are dead when i click on them. do you have the links for them. thanks


Share this post

Link to post
Share on other sites

right this is a new issue on the dongle startup. a new install on a MacPRo 1,1 snow leopard. just install my EIAS and i get a hardware dongle error on launching Animator.

I have done 2 reinstall from my original disk to the web download and reboots. I've install the dongle software and lion patch updates and restarts. no luck. any ideas ?

All i get is the error dialog "Hardware key error: INVALID_FUNCTION_CODE #1" everytime.

Share this post

Link to post
Share on other sites

okay i reinstall the dongle lion patched updated one and didnt work but then manually put the frameworks in and all is fine again.

Looks like the dongle installer just didnt want to put in the eve3 frame in. anyway all is well in teh world again with my new/old MacPro 1,1.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...