Jump to content
Juanxer

Animator 9.1 suddenly unable to start, weird error msgs

Recommended Posts

I've been working with EIAS on my Mac today normally, and suddenly Animator is failing to launch, showing this message:

Assertion failed on line 24 of file Dbg_InitCounter.cpp: Failed to call Dbg_InitCounter::ShouldCleanUp() enough times to balance Dbg_InitCounter::ShouldInit()

then it crashes and produces a standard macOS app crash error dialog.

As I had shoved the USB key a little while repositioning a side screen, I tried putting it in another USB socket, to no avail (unplugging it produces the usual alert in such cases, so it doesn't seem to be that). Then I tried installing a fresh copy. Upon entering my activation code, Animator shows one of its own alert messages saying:

Cannot allocate needed 3D icon "IconBody_Camera" from EIResource folder

Those folder and file are there, fresh from the disk image file. This message doesn't appear when I launch the non-fresh Animator (or possibly it goes out too fast to be seen).

I've restarted the Mac, without results. Before I try more drastic steps, is this something that sounds familiar to anyone and suggests how to solve it?

I'm on an old hexacore Mac Pro, running macOS Sierra 10.12.6

Share this post


Link to post
Share on other sites

Ola Juanxer!

You probably updated the OSX, its the new Permission problem on the new OS..

please, install teamviewer.com and send me the ID and Pass which appears when you open teamviewer, I will remotely change for you :)

Thanks

Tom

Share this post


Link to post
Share on other sites

Hi, Tomas. As far as I've checked, I'm still on macOS Sierra 10.12.6 (I've been there for several months), and the last significant change done was Security Update 2018-005, which I ran last Thursday, so whatever happened between saturday morning and the following afternoon hasn't been an OS change.

I'm grateful for your offer for immediate help, but it's not that terribly urgent (I can run EIAS in a PC of mine instead, in the meantime) and I would rather read about those permission problems you mention, if you can point me to some article about them.

Share this post


Link to post
Share on other sites

Tomas, might it be that the private messaging isn't working? I sent a couple of messages already.

As it is 2:00am here, I'm going to go to sleep :) . As I told you, this is not really urgent, and I wouldn't want to ruin your weekend, so we can leave it for monday or later. And, anyway, if there's any permissions settings recipe you might care to point me to, possibly I could take care of it.

Edited by Juanxer
I'm sleepy :D

Share this post


Link to post
Share on other sites

Hola, Tom  :) 

This morning I've checked a bootable backup from some days ago in which EIAS still worked and have restored it fairly quickly, so for the time being there's no longer any urgency. That said, it probably would be best to post somewhere how we ought to deal with those last updates from Apple.

In any case, thank you so much for your prompt offer to assist me. You are a lifesaver!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×