Jump to content
monday1313

DOF shader issue

Recommended Posts

Hi, I reported this error before for version 7... I was told that it had been fixed for version 8...maybe the version I downloaded didn't have the right version of the shader in it. It is version 1.0.

There are 2 issues:

1. The glow layer makes it impossible to export a movie (from whatever compositing app I try) with an alpha channel that is useable.

2. The second issue which is the real pain in the butt is that using a single instance of camera, I get shifts in the image like in the attached.

Thanks!

post-72-13269393551162_thumb.png

post-72-13269393551819_thumb.png

Share this post


Link to post
Share on other sites

Hi, monday1313

Hi, I reported this error before for version 7... I was told that it had been fixed for version 8...maybe the version I downloaded didn't have the right version of the shader in it. It is version 1.0.

No, it was not fixed in EI8

1. The glow layer makes it impossible to export a movie (from whatever compositing app I try) with an alpha channel that is useable.

Don't understand a relation with glow and alpha. Please explain more.

2. The second issue which is the real pain in the butt is that using a single instance of camera, I get shifts in the image like in the attached.

If you render in strips - this artifact is unavoidable. But if (as you wrote) with single Camera - so it's definitely a bug that should be fixed.

For a separated shader the fix can come before EI9. But anyway a minimal sample prj is needed. We remember a scene with apple that had same prob. but after several hours of RT shadows on our old G4 700 we still could not figure out what's wrong there. So please help with project.

Thanks

Share this post


Link to post
Share on other sites

Hi Tomas, Hi Igors,

While, in the process of minimizing the project. I tried rendering with only one "peep". The error didn't happen. So I made it about 24 peeps, This is about 4 million polys. Rendering this many polys made a single instance of camera divide it up into sections while rendering it. In the part where it writes the image to the preview window in camera, it get's done in strips. Sure enough, the final render had those errors in it. So I'm pm'ing you a link to a version of the project.

As for the alpha/glow issue. I'll work on explaining that in a minute.

Thanks!

Share this post


Link to post
Share on other sites

Hi monday1313,

We've d/loaded Peep_bug_test_v1.002.zip from you.

However, the archive contains only FACT files, no project there.

we need a simplified project which contain everything we are supposed to only open the EIAS prj and render and see the bug with a Read me inside with your description step by step How we see this bug.

Thanksss

Tomas & Igors

Share this post


Link to post
Share on other sites

did you get the file ok? I didn't put a description in there because I already described it above. literally just hit render and you will see the bug in the psd file.

Share this post


Link to post
Share on other sites

Hi, monday1313

did you get the file ok? I didn't put a description in there because I already described it above. literally just hit render and you will see the bug in the psd file.

Yes, everything is received and already fixed. Unfortunately, it was a series of bugs not only in the shader, but also in Camera. Thus you can't use the fix immediately

Thanks

Share this post


Link to post
Share on other sites

Hi Igors,

Great thanks! Any idea when Camera might be updated then?

Hi, monday1313

Yes, everything is received and already fixed. Unfortunately, it was a series of bugs not only in the shader, but also in Camera. Thus you can't use the fix immediately

Thanks

Share this post


Link to post
Share on other sites

Hi Monday,

That'll be a a short while i'm afraid. As Tomas has said, Camera is currently undergoing surgery, once the current tasks are done, we can give you a more accurate date, sorry I can't be of more help. Suffice to say, it will be as soon as humanly possible!

Best,

Ian

Share this post


Link to post
Share on other sites

Hi, monday1313

Any idea when Camera might be updated then?

We've not too much to add to what Ian has said. Yes, Camera is now "unmounted" for fundamental EI9 features. So now we can't give any update promises.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×